Добро пожаловать на сайт Bitrix Q&A, где вы можете задавать вопросы о программировании и разработке на Битрикс и получать быстрые и квалифицированные ответы от профессионалов!




CIBlockSection::GetList отказывается выдавать ELEMENT_CNT

0 голосов
Добрый день!

И снова - какая то мистика.
Чтобы не быть многословным - просто привожу, код. Благо он элементарный.

Код
$rsMainSectionList = CIBlockSection::GetList(
                     array(
                        'SORT' => 'ASC'
                        ), 
                     array(
                        'IBLOCK_ID'  => $arParams['IBLOCK_ID'],
                        'SECTION_ID' => 0,
                        'ACTIVE'     => 'Y',
                        'CNT_ACTIVE' => 'Y',
                     ),
                     true,
                     array(
                        'ID', 
                        'NAME', 
                        'UF_1138', // не активная картинка
                        'UF_1139', // активная картинка
                        'DEPTH_LEVEL',
                        'ELEMENT_CNT',
                     )
                  );
                  

// складываем в массив основные рубрики
$INDEX = 0;
while ( $arMainList = $rsMainSectionList->GetNext() )
{
   $ID       = $arMainList['ID'];
   $NAME       = $arMainList['NAME'];
   $DEPTH       = $arMainList['DEPTH_LEVEL'];
   $ACTIVE    = CFile::GetPath($arMainList['UF_1138']); // неактивная картинка
   $INACTIVE    = CFile::GetPath($arMainList['UF_1139']);// активная картинка
   $ELEMENT_CNT = $arMainList['ELEMENT_CNT'];
   
   $SECTIONS[$INDEX] = array( 
                     'ID'       => $ID,
                     'PARENT'    => 0,
                     'NAME'       => $NAME,
                     'IMG_INACTIVE'    => $ACTIVE, // не активная картинка
                     'IMG_ACTIVE'    => $INACTIVE, // активная картинка
                     'LEVEL'    => $DEPTH,
                     'ELEMENT_CNT' => $ELEMENT_CNT,
                  );
   
      
   $INDEX++;
}



На выходе $ELEMENT_CNT стабильно 0
Хотя я точно знаю что там они есть :(
спросил 17 Ноя, 13 от HeJIJIu (630 баллов)

5 Ответы

0 голосов
SQL запрос какой формируется7
ответил 03 Янв, 14 от JIETYHOK (2,260 баллов)
0 голосов
CNT_ACTIVE' => 'Y' нужно не в фильтр передавать а следующим параметром, вместо true.
http://dev.1c-bitrix.ru/api_help/iblock/classes/ciblocksection/getlist.php
ответил 18 Апр, 14 от NitroGeN (2,840 баллов)
0 голосов
Цитата
Евгений Малков пишет:
CNT_ACTIVE' => 'Y' нужно не в фильтр передавать а следующим параметром, вместо true.

:) читайте внимательнее:
Цитата
При этом arFilter дополнительно обрабатывает следующие фильтруемые поля:


Думается мне, что причина в списке выбираемых полей, ELEMENT_CNT - лишнее поле.
ответил 12 Авг, 14 от Delp (7,220 баллов)
0 голосов
Спасибо :)
обязательно попробую... после праздников ;)
ответил 17 Дек, 14 от HeJIJIu (630 баллов)
0 голосов
решилась проблема?  ато у меня то же самое ((( и ничего не помогает
ответил 07 Апр, 15 от Rozie (100 баллов)

Похожие вопросы

0 голосов
3 ответов
спросил 07 Март, 14 от aisigylka (100 баллов)
0 голосов
2 ответов
0 голосов
2 ответов
спросил 28 Ноя, 13 от Duffel (100 баллов)
0 голосов
3 ответов
спросил 12 Ноя, 13 от Snezhka (2,240 баллов)
0 голосов
5 ответов
спросил 02 Сен, 13 от AngryKid (420 баллов)