Добро пожаловать на сайт Bitrix Q&A, где вы можете задавать вопросы о программировании и разработке на Битрикс и получать быстрые и квалифицированные ответы от профессионалов!


Поломался переход на детальную страницу новости

0 голосов

Использую комплексный компонент news, вчера переход на детальную страницу работал нормально, сегодня переходит по url "katalog-nedvizhimosti/5/" и показывает шаблон каталога. К знает в чем может быть причина?
 

<?$APPLICATION->IncludeComponent(
"bitrix:news", 
"news_catalog-h", 
array(
"ADD_ELEMENT_CHAIN" => "N",
"ADD_SECTIONS_CHAIN" => "Y",
"AJAX_MODE" => "N",
"AJAX_OPTION_ADDITIONAL" => "",
"AJAX_OPTION_HISTORY" => "N",
"AJAX_OPTION_JUMP" => "N",
"AJAX_OPTION_STYLE" => "Y",
"BROWSER_TITLE" => "-",
"CACHE_FILTER" => "N",
"CACHE_GROUPS" => "Y",
"CACHE_TIME" => "36000000",
"CACHE_TYPE" => "A",
"CHECK_DATES" => "Y",
"DETAIL_ACTIVE_DATE_FORMAT" => "d.m.Y",
"DETAIL_DISPLAY_BOTTOM_PAGER" => "Y",
"DETAIL_DISPLAY_TOP_PAGER" => "N",
"DETAIL_FIELD_CODE" => array(
0 => "PREVIEW_PICTURE",
1 => "",
),
"DETAIL_PAGER_SHOW_ALL" => "Y",
"DETAIL_PAGER_TEMPLATE" => "",
"DETAIL_PAGER_TITLE" => "Страница",
"DETAIL_PROPERTY_CODE" => array(
0 => "NAME",
1 => "SPACE",
2 => "DESC",
3 => "FIELD",
4 => "PRICE",
5 => "IMAGES_C",
6 => "",
),
"DETAIL_SET_CANONICAL_URL" => "N",
"DISPLAY_BOTTOM_PAGER" => "Y",
"DISPLAY_DATE" => "Y",
"DISPLAY_NAME" => "Y",
"DISPLAY_PICTURE" => "Y",
"DISPLAY_PREVIEW_TEXT" => "Y",
"DISPLAY_TOP_PAGER" => "N",
"HIDE_LINK_WHEN_NO_DETAIL" => "N",
"IBLOCK_ID" => "2",
"IBLOCK_TYPE" => "goods",
"INCLUDE_IBLOCK_INTO_CHAIN" => "N",
"LIST_ACTIVE_DATE_FORMAT" => "d.m.Y",
"LIST_FIELD_CODE" => array(
0 => "PREVIEW_PICTURE",
1 => "",
),
"LIST_PROPERTY_CODE" => array(
0 => "NAME",
1 => "SPACE",
2 => "DESC",
3 => "FIELD",
4 => "PRICE",
5 => "IMAGES_C",
6 => "",
),
"MESSAGE_404" => "",
"META_DESCRIPTION" => "-",
"META_KEYWORDS" => "-",
"NEWS_COUNT" => "5",
"PAGER_BASE_LINK_ENABLE" => "N",
"PAGER_DESC_NUMBERING" => "N",
"PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
"PAGER_SHOW_ALL" => "N",
"PAGER_SHOW_ALWAYS" => "N",
"PAGER_TEMPLATE" => ".default",
"PAGER_TITLE" => "Новости",
"PREVIEW_TRUNCATE_LEN" => "",
"SEF_FOLDER" => "/katalog-nedvizhimosti/",
"SEF_MODE" => "Y",
"SET_LAST_MODIFIED" => "N",
"SET_STATUS_404" => "N",
"SET_TITLE" => "Y",
"SHOW_404" => "N",
"SORT_BY1" => "ACTIVE_FROM",
"SORT_BY2" => "SORT",
"SORT_ORDER1" => "DESC",
"SORT_ORDER2" => "ASC",
"USE_CATEGORIES" => "N",
"USE_FILTER" => "N",
"USE_PERMISSIONS" => "N",
"USE_RATING" => "N",
"USE_RSS" => "N",
"USE_SEARCH" => "N",
"USE_SHARE" => "N",
"COMPONENT_TEMPLATE" => "news_catalog-h",
"SEF_URL_TEMPLATES" => array(
"news" => "",
"section" => "",
"detail" => "#ELEMENT_CODE#/ ",
)
),
false
);?>
 
Настройки инфоблока
#SITE_DIR#/katalog-nedvizhimosti/
пусто
#SITE_DIR#/katalog-nedvizhimosti/#ELEMENT_CODE#/ 
закрыто с пометкой: Ответ так и не появился...
спросил 06 Апр от аноним
закрыто 10 Апр
bitrix...
Менял ЧПУ ссылку на детальную страницу, вернулся опять к #ELEMENT_CODE#/
и все опять заработало....
WTF!?
Кто нибудь объясните что за хрень?
Не очень понятно что происходило. #ELEMENT_CODE# или #ELEMENT_ID# - тоже непонятно... Кстати при редактировании настроек компонентов в виз.редакторе меняется ещё файлик /urlrewrite.php -- может в нём что-то накручено, бывает и так.

Управление продуктом: аналитика, разработка, продвижение